Перейти к содержимому


Фото
- - - - -

Not Found на всех страницах кроме главной


  • Чтобы отвечать, сперва войдите на форум
8 ответов в теме

#1 yrj

yrj
  • Пользователь
  • 1 сообщений

Опубликовано 25.05.2012 - 10:14

Установил Симплу 2, главная страница открывается, но списка товаров на ней нет, только надпись "Страница не найдена". Всех остальных страниц как-будто вообще нет.
На какую ссылку не нажму, получаю что-то типа

Not Found

The requested URL /simpla/catalog/mobilnye_telefony was not found on this server.



#2 pikusov

pikusov

    Автор Simpla CMS

  • Администратор
  • 946 сообщений

Опубликовано 25.05.2012 - 10:40

Нужно включить mod_rewrite на хостинге



#3 proffzulus

proffzulus
  • Пользователь
  • 2 сообщений

Опубликовано 15.08.2012 - 03:27

Та же проблема, mod_rewrite включен, RewriteBase / в .htaccess присутствует.
Любая ссылка из свежего инсталла не работает, например example.ru/blog или домен.ru/test.
При этом из админки эта страница доступна, её можно редактировать.
Никак не могу понять в чём проблема.



#4 proffzulus

proffzulus
  • Пользователь
  • 2 сообщений

Опубликовано 15.08.2012 - 03:29

Надпись при этом немного другая. Корректно отображается страница /404. Любые изменения, которые я в ней делаю, отображаются. Дизайн корректный, но вместо вывода страниц - 404.



#5 SashaYa

SashaYa
  • Пользователь
  • 4 сообщений

Опубликовано 18.08.2012 - 16:56

таже проблема (



#6 alexmercer

alexmercer
  • Пользователь
  • 4 сообщений

Опубликовано 28.09.2012 - 05:00

Сталкивался с этой проблемой еще в начале лета, и mod_rewrite включен, и RewriteBase / в .htaccess есть, а проблема не исчезла. Отказался от использования симплы именно на почве отсутствия достаточной поддержки. Судя по всему довольно распространенная эта проблема, а вот решения не вижу.
Хотелось бы все таки обратить внимание разработчиков, может в FAQ какой-то добавить описание как ее решить/избежать...



#7 pikusov

pikusov

    Автор Simpla CMS

  • Администратор
  • 946 сообщений

Опубликовано 28.09.2012 - 08:19

api/Request.php

[code] if($type == 'string')
return strval(preg_replace('/[^\p{L}\p{Nd}\d\s_\-\.\%\s]/ui', '', $val));
[/code]

заменить на

if($type == 'string')
    		return strval($val);



#8 Theo

Theo
  • Пользователь
  • 5 сообщений
  • Верстка, Заказчик
  • Версия CMS:2.x
  • Откуда:Украина

Опубликовано 14.10.2016 - 15:12

<VirtualHost *:80>
    ServerName shop.mydomain.com
    DocumentRoot /home/.../SitesRoot/site
    <Directory /home/.../SitesRoot/site>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride All
        Order allow,deny
        allow from all
    </Directory>
</VirtualHost>


#9 ProWebStroy

ProWebStroy
  • Пользователь
  • 1 сообщений
  • Программирование, Верстка, Пользователь
  • Откуда:Москва

Опубликовано 02.12.2017 - 13:56

Просто у вас пустой .htacces. Сталкивался с такой проблемой после настройки все зараюотало..






0 пользователей читают эту тему

0 пользователей, 0 гостей, 0 скрытых