Перейти к содержимому


Фото
- - - - -

  в редакторе товаров


  • Чтобы отвечать, сперва войдите на форум
2 ответов в теме

#1 KeNs

KeNs
  • Пользователь
  • 21 сообщений
  • Пользователь
  • Версия CMS:2.x

Опубликовано 12.03.2019 - 18:38

Привет всем! Подскажите такой момент, если сделать описание товара через редактор, а потом открыть html версию, то вместо пробелов там видим: " ", я понимаю что это и есть пробел )... но как сделать так что бы редактор просто ставил пробел, без использования " ". Просто я как то решил добавится в яндекс маркет, всё прошло, но сказали убрать символы " " в товарах. Теперь приходится всё вручную перепроверять, хочется в новых товарах исправить эту проблему на начальном уровне.



#2 KeNs

KeNs
  • Пользователь
  • 21 сообщений
  • Пользователь
  • Версия CMS:2.x

Опубликовано 16.03.2019 - 12:41

Решение: открыть /simpla/design/html/tinymce_init.tpl и добавить     entity_encoding: 'raw', у меня это выглядит так:

 

  tinyMCE.init({literal}{{/literal}
	// General options
	mode : "specific_textareas",
	editor_selector : /editor/,
	theme : "advanced",
	language : "ru",
	theme_advanced_path : false,
	apply_source_formatting : false,
	plugins : "jaretypograph,smimage,smeditimage,smexplorer,safari,spellchecker,style,table,save,advimage,advlink,autolink,inlinepopups,media,contextmenu,paste,fullscreen,noneditable,visualchars,nonbreaking,xhtmlxtras",
	relative_urls : false,
	remove_script_host : true,
	convert_urls : true,
	verify_html: false,
    remove_linebreaks : false,
    content_css :"../design/{$settings->theme}/css/tinystyle.css",
    spellchecker_languages : "+Russian=ru,+English=en",
	entity_encoding: 'raw',


#3 Gruzin

Gruzin
  • Пользователь
  • 437 сообщений
  • Верстка, Пользователь
  • Версия CMS:2.x
  • Откуда:Минск

Опубликовано 16.03.2019 - 12:45

Решение: открыть /simpla/design/html/tinymce_init.tpl и добавить     entity_encoding: 'raw', у меня это выглядит так:

 

  tinyMCE.init({literal}{{/literal}
	// General options
	mode : "specific_textareas",
	editor_selector : /editor/,
	theme : "advanced",
	language : "ru",
	theme_advanced_path : false,
	apply_source_formatting : false,
	plugins : "jaretypograph,smimage,smeditimage,smexplorer,safari,spellchecker,style,table,save,advimage,advlink,autolink,inlinepopups,media,contextmenu,paste,fullscreen,noneditable,visualchars,nonbreaking,xhtmlxtras",
	relative_urls : false,
	remove_script_host : true,
	convert_urls : true,
	verify_html: false,
    remove_linebreaks : false,
    content_css :"../design/{$settings->theme}/css/tinystyle.css",
    spellchecker_languages : "+Russian=ru,+English=en",
	entity_encoding: 'raw',

Спасибо, что всем поведали.






0 пользователей читают эту тему

0 пользователей, 0 гостей, 0 скрытых