Перейти к содержимому


Фото
- - - - -

Не отображаются товары после переноса simpla 1.4 на 2.3.8


  • Чтобы отвечать, сперва войдите на форум
5 ответов в теме

#1 esistema1

esistema1
  • Пользователь
  • 108 сообщений

Опубликовано 04.01.2018 - 12:39

В каталоге товаров после обновления вылетают ошибки и товары не отображаются

 

Warning: Invalid argument supplied for foreach() in /var/www/clients/client1/web15/test2/view/View.php on line 143

Warning: Invalid argument supplied for foreach() in /var/www/clients/client1/web15/test2/view/View.php on line 220

 

А вот строки 143 и 220 из файла view

foreach($this->products->get_products(array('id'=>$browsed_products_ids, 'visible'=>1)) as $p)




foreach($this->products->get_products($params) as $p)

 

Сами товары можно открыть по прямым ссылкам /products/url

 

Подскажите пожалуйста как исправить?



#2 esistema1

esistema1
  • Пользователь
  • 108 сообщений

Опубликовано 04.01.2018 - 12:52

Проблема решена



#3 ST_RU

ST_RU

    Главный по шаблонам

  • Фрилансер
  • 785 сообщений
  • Дизайн, Программирование, Верстка
  • Версия CMS:2.x
  • Откуда:Siberia, Nsk

Опубликовано 04.01.2018 - 16:46

хотел помочь  :)



#4 Alexica

Alexica
  • Пользователь
  • 6 сообщений
  • Пользователь
  • Откуда:Украина

Опубликовано 09.01.2018 - 15:03

В каталоге товаров после обновления вылетают ошибки и товары не отображаются

 

Warning: Invalid argument supplied for foreach() in /var/www/clients/client1/web15/test2/view/View.php on line 143

Warning: Invalid argument supplied for foreach() in /var/www/clients/client1/web15/test2/view/View.php on line 220

 

А вот строки 143 и 220 из файла view

foreach($this->products->get_products(array('id'=>$browsed_products_ids, 'visible'=>1)) as $p)




foreach($this->products->get_products($params) as $p)

 

Сами товары можно открыть по прямым ссылкам /products/url

 

Подскажите пожалуйста как исправить?

а как Вы решили эту проблему, сможете подсказать?



#5 esistema1

esistema1
  • Пользователь
  • 108 сообщений

Опубликовано 10.01.2018 - 23:24

У меня до переноса был создано дополнительное поле в таблице s_products (отвечающее за сортировку по популярности), после переноса надо было его создать заново и все заработало.



#6 Alexica

Alexica
  • Пользователь
  • 6 сообщений
  • Пользователь
  • Откуда:Украина

Опубликовано 15.01.2018 - 13:50

У меня до переноса был создано дополнительное поле в таблице s_products (отвечающее за сортировку по популярности), после переноса надо было его создать заново и все заработало.

спасибо большое за ответ

ps админы, а можно добавить кнопку на форуме "СПАСИБО"?






0 пользователей читают эту тему

0 пользователей, 0 гостей, 0 скрытых