Перейти к содержимому


Фото
- - - - -

Simpla 2.1.0


  • Чтобы отвечать, сперва войдите на форум
74 ответов в теме

#1 pikusov

pikusov

    Автор Simpla CMS

  • Пользователь
  • 948 сообщений

Опубликовано 22.02.2012 - 06:54

Посмотреть можно тут
http://demo.simplacms.ru/

Скачать
http://simplacms.ru/simpla.zip

<b>Как обновить с версии 2.0:</b>
0) обязательно сделайте бекап в панели управления хостингом (а не в симпле!)
1) выполните SQL-скрипт update/update_2.0_to_2.1.sql (если у вас 2.1 RC, то это делать не нужно)
2) залейте файлы (из архива simpla_source.zip) на FTP "поверх старых" кроме файлов /simpla/.htaccess и /simpla/.passwd (они должны остаться старыми)
3) нужно поправить конфиг - скопируйте из simpla.ini.php строки с доступом к базе и лицензией в новый файл /config/config.php

<b>Изменения в шаблонах</b>
1) Шаблон hits.tpl переименован в main.tpl
2) Переменные $product->hit переименованы в $product->featured

Кстати, симпла отлично себя чувствует на iphone и ipad:
<img src="http://blog.simplacm..._frontend.png">
<img src="http://blog.simplacm...pad_admin.png">



#2 anton

anton
  • Пользователь
  • 68 сообщений

Опубликовано 22.02.2012 - 07:52

Почему новую тему начали ?



#3 pikusov

pikusov

    Автор Simpla CMS

  • Пользователь
  • 948 сообщений

Опубликовано 22.02.2012 - 07:56

В прошлой теме всё было завалено оффтопом. Прошу тут обсуждать только то что касается версии 2.1 и обновления до неё.



#4 Kollipso

Kollipso
  • Пользователь
  • 5 сообщений

Опубликовано 22.02.2012 - 11:04

Не пойму в чем беда, но админка стала отображаться в кривой кодировке - windows-1251, хотя везде прописано utf-8 и ничего не менял( проверял на нескольких машинах и браузерах - автоопределение неверное( хотя основной сайт отображается нормально.



#5 pikusov

pikusov

    Автор Simpla CMS

  • Пользователь
  • 948 сообщений

Опубликовано 22.02.2012 - 11:24

Добавьте в .htaccess строку
AddDefaultCharset UTF-8



#6 Kollipso

Kollipso
  • Пользователь
  • 5 сообщений

Опубликовано 22.02.2012 - 11:35

Есть, причем в двух htaccess'ах(( - корне и simpla, уже везде где мог проставил, переставил с нуля сайт - выдает в windows-1251



#7 alinamolchanova

alinamolchanova
  • Пользователь
  • 121 сообщений

Опубликовано 22.02.2012 - 11:38

после установки на sweb не включает шаблон, дефолтный работает, а тот что делали нет, на другом хостинге все работает - симплу ставили с 0. в чем может быть проблема?



#8 pikusov

pikusov

    Автор Simpla CMS

  • Пользователь
  • 948 сообщений

Опубликовано 22.02.2012 - 11:42

> Есть, причем в двух htaccess'ах(( - корне и simpla, уже везде где мог проставил, переставил с нуля сайт - выдает в windows-1251
Возможно в настройках хостинга есть переключение кодировки.
А так же попробуйте написать в .htaccess:
php_value default_charset utf-8



#9 pikusov

pikusov

    Автор Simpla CMS

  • Пользователь
  • 948 сообщений

Опубликовано 22.02.2012 - 11:43

> после установки на sweb не включает шаблон, дефолтный работает, а тот что делали нет, на другом хостинге все работает - симплу ставили с 0. в чем может быть проблема?
Проверьте есть ли права на запись в папку /compiled/



#10 SupermarioBros

SupermarioBros
  • Пользователь
  • 19 сообщений

Опубликовано 22.02.2012 - 11:46

Покажется не разумным, но попробуйте закомментировать в api/Database.php эти строки
/*
// Настраиваем соединение
if($this->config->db_charset)
mysql_query('SET NAMES '.$this->config->db_charset, $this->link);
*/



#11 SupermarioBros

SupermarioBros
  • Пользователь
  • 19 сообщений

Опубликовано 22.02.2012 - 11:48

просто были случаи когда mysql_query('SET NAMES utf8'); приводил к кракозябрам, хотя везде было утф-8



#12 Kollipso

Kollipso
  • Пользователь
  • 5 сообщений

Опубликовано 22.02.2012 - 11:54

>Возможно в настройках хостинга есть переключение кодировки.
>А так же попробуйте написать в .htaccess:
>php_value default_charset utf-8
В настройка сервера выставил по-умолчанию utf-8 ноль реакции, а вот php_value в htaccess все заработало, большое спасибо!

>просто были случаи когда mysql_query('SET NAMES utf8'); приводил к кракозябрам, хотя везде было утф-8
Странно другое, что основной сайт (не админка) - работает нормально, но там я писал сам дизайн, а вот админка - выдает кракозябры, но php_value помогло.



#13 alinamolchanova

alinamolchanova
  • Пользователь
  • 121 сообщений

Опубликовано 22.02.2012 - 12:02

и там и в админдизайне 777 и просто компил, не помогло



#14 Kollipso

Kollipso
  • Пользователь
  • 5 сообщений

Опубликовано 22.02.2012 - 12:44

>после установки на sweb не включает шаблон, дефолтный работает, а тот что делали нет, на другом хостинге все работает - симплу ставили с 0. в чем может быть проблема?
Попробуйте сделать копию с дефолтного, появится папка design/default_1 и в нее скопируйте свой шаблон.



#15 dolphin

dolphin
  • Пользователь
  • 199 сообщений
  • Откуда:Ростов-на-Дону

Опубликовано 24.02.2012 - 01:37

не знаю в чем дело, но и в 2.0 была такая странность
загружаю логотип в одном цветовом тоне, а он загружается в другом который тоже есть
не пойму, меняю название все равно так, в чем может быть дело ?



#16 dolphin

dolphin
  • Пользователь
  • 199 сообщений
  • Откуда:Ростов-на-Дону

Опубликовано 24.02.2012 - 01:44

изменил размер и загрузился нормально, видимо старый файл не заменяется на новый при каком то равенстве



#17 rand

rand
  • Пользователь
  • 53 сообщений

Опубликовано 24.02.2012 - 03:19

Картинка была в кэше (прокси или браузера).



#18 dolphin

dolphin
  • Пользователь
  • 199 сообщений
  • Откуда:Ростов-на-Дону

Опубликовано 24.02.2012 - 05:01

как изменить размер кнопки "в корзину" ?
а еще лучше расположить ее после цены



#19 rand

rand
  • Пользователь
  • 53 сообщений

Опубликовано 24.02.2012 - 05:19

уменьшить в цсс, изменить положение в шаблоне



#20 dolphin

dolphin
  • Пользователь
  • 199 сообщений
  • Откуда:Ростов-на-Дону

Опубликовано 24.02.2012 - 06:07

если у товара например 4 фотки, так и задумано что они идут в столбик ?
раньше было по 2 в линию, дальше с новой строки, сейчас вижу большую фотку и дальше 3 вниз
http://dvabrata.ru/p...tronic_bece1500






0 пользователей читают эту тему

0 пользователей, 0 гостей, 0 скрытых