Перейти к содержимому


Фото
- - - - -

Сжатие и объединение css и js в шаблоне.


  • Чтобы отвечать, сперва войдите на форум
26 ответов в теме

#21 ABSORBER

ABSORBER
  • Модератор
  • 437 сообщений
  • Дизайн, Программирование, Верстка
  • Версия CMS:2.x
  • Откуда:Хабаровск

Опубликовано 13.03.2017 - 06:00

Уважаемый, Absorber!

Прошу меня простить, что я не уточнил. 

Так как сижу на модификации Simpla (OkayCMS).

Ваше решение было бы очень незаменимо в работе моего ИМ. 

Если Вам будет не сложно, укажите как данное ГР внедрить в Ok. (Free use)

Понятия не имею, с Okaycms плотно не работал, но уверен что все должно работать, т.к. OkayCMS 100% клон Симплы.

Надо смотреть логи PHP. Возможно не подходит версия.

Либо ковырять Smarty, может проблема там.

 

Если интересует коммерческое решение проблемы, пишите. Контакты ниже



#22 ahmed

ahmed
  • Пользователь
  • 172 сообщений
  • Программирование, Пользователь
  • Версия CMS:2.x
  • Откуда:Россия

Опубликовано 13.03.2017 - 08:45

Использующиеся в разработке файлы PHP содержат конструкции типа

 

return [];

 

Однако, использовать короткий синтаксис определения массивов, который заменяет языковую конструкцию array() на [], возможно лишь начиная с PHP 5.4.

 

А поскольку Simpla, по официальной документации, работает на PHP начиная с 5.2, то использование в дополнении таких конструкций несколько некорректно. Автору следовало бы поправить свою разработку. 


Изменено: ahmed, 13.03.2017 - 08:45


#23 sergeevizh

sergeevizh
  • Пользователь
  • 83 сообщений
  • Откуда:Москва

Опубликовано 13.03.2017 - 18:31

Понятия не имею, с Okaycms плотно не работал, но уверен что все должно работать, т.к. OkayCMS 100% клон Симплы.

Надо смотреть логи PHP. Возможно не подходит версия.

Либо ковырять Smarty, может проблема там.

 

Если интересует коммерческое решение проблемы, пишите. Контакты ниже

Ошибка все та же, тестирую на своем компьютере через EleanorServ 

 

У меня не получилось

 

PHP Parse error:  syntax error, unexpected '[' in /********/Smarty/libs/plugins/sacy/sacy.php on line 138

 

$group = serialize($this->_cfg->get('merge_tags') ? [$attrs['media'], $attrs['type']] : [$attrs['media']]);


#24 ABSORBER

ABSORBER
  • Модератор
  • 437 сообщений
  • Дизайн, Программирование, Верстка
  • Версия CMS:2.x
  • Откуда:Хабаровск

Опубликовано 14.03.2017 - 04:38

ИА поскольку Simpla, по официальной документации, работает на PHP начиная с 5.2, то использование в дополнении таких конструкций несколько некорректно. Автору следовало бы поправить свою разработку. 

 

Последняя версия Simpla работает на php 5.6 без ошибок.

С момента последнего релиза прошло около 2х лет. Могли бы обновиться.

 

И кстати, там дело не только в массивах, раз ух хотите на 5.2 использовать



#25 ahmed

ahmed
  • Пользователь
  • 172 сообщений
  • Программирование, Пользователь
  • Версия CMS:2.x
  • Откуда:Россия

Опубликовано 14.03.2017 - 08:11

Последняя версия Simpla работает на php 5.6 без ошибок.
С момента последнего релиза прошло около 2х лет. Могли бы обновиться.
 
И кстати, там дело не только в массивах, раз ух хотите на 5.2 использовать

 
Поднятый вопрос не в этом, а в том, что официально системные требования Simpla включают PHP 5.2 или выше. На странице
http://simplacms.ru/features.html
можно видеть "Требования к хостингу ... PHP 5.2 и выше ...".  Стало быть, и все доработки для Simpla должны работать на php 5.2 или выше. А Ваша не идет на PHP 5.2.  Если уж никак не хотите приводить в соответствие с текущими стандартами Simpla, то хотя бы надо предупреждать пользователей в описании о своих специфических системных требованиях...

Изменено: ahmed, 14.03.2017 - 08:13


#26 ABSORBER

ABSORBER
  • Модератор
  • 437 сообщений
  • Дизайн, Программирование, Верстка
  • Версия CMS:2.x
  • Откуда:Хабаровск

Опубликовано 14.03.2017 - 10:15

 
Поднятый вопрос не в этом, а в том, что официально системные требования Simpla включают PHP 5.2 или выше. На странице
http://simplacms.ru/features.html
можно видеть "Требования к хостингу ... PHP 5.2 и выше ...".  Стало быть, и все доработки для Simpla должны работать на php 5.2 или выше. А Ваша не идет на PHP 5.2.  Если уж никак не хотите приводить в соответствие с текущими стандартами Simpla, то хотя бы надо предупреждать пользователей в описании о своих специфических системных требованиях...

я не видел что бы ВЫ поднимали какой-нибудь вопрос. 

Тот кто спросил, сказал просто "у меня не работает" и все. Нет ни логов, ни ошибок ничего!!! 

 

Нет уважаемый, доработка бесплатная и не поддерживаемая. Я не официальный разработчик что бы Вам что-то обещать и быть обязанным.

Так ладно бы если доработка была платной, и лично вы заплатили деньги за неё, тогда было бы за что спрашивать "Я купил, у меня не работает". 

А вы тут притензии и какие-то права качаете.

 

Решил поделиться наработкой, которую делал еще год назад.

В этом посте указал на каких параметрах она у меня работает - http://forum.simplac...аблоне/?p=77017



#27 ahmed

ahmed
  • Пользователь
  • 172 сообщений
  • Программирование, Пользователь
  • Версия CMS:2.x
  • Откуда:Россия

Опубликовано 14.03.2017 - 13:12

Я всего лишь поднял вопрос такой: если официальная Simpla работает на PHP не ниже 5.2, то вполне естественно было бы, если бы при тех же условиях функционировали и доработки.

 

С моей стороны было лишь ПОЖЕЛАНИЕ, на которое Вы вольны отреагировать или проигнорировать. Требований к Вам никаких не выдвигалось, нет оснований для столь бурной реакции.  Не хотите затратить несколько минут, чтоб поднять уровень своего продукта - дело Ваше.

 

Ребята, давайте жить дружно.

Просьба не волноваться и не переживать, никто с Вас ничего не требует, Вы никому ничего не обязаны.






0 пользователей читают эту тему

0 пользователей, 0 гостей, 0 скрытых